» Home » technology » Digispark – The micro-sized, affordable, Arduino enabled, USB development board!

Digispark – The micro-sized, affordable, Arduino enabled, USB development board!

You can find out more at digistump.com and get help on the digistump Wiki.

[Do not plug in your digispark before installing the Driver!!!]

Setting up your digispark in Windows for the 1st time use, including Windows 8.1

Tested on Windows 8.1 Pro, so not sure if this applies to Windows 8.

  • I know you’re excited but don’t plug your digispark in just yet, drivers need to be installed beforehand
  • Download the Arduino IDE (v1.04) with the Digispark Addons
  • Unzip the Arduino IDE to an easily accessible directory
  • For Windows 8 & 8.1 you must disable driver signature verification. This will restart your PC – Instructions here: http://www.howtogeek.com/167723/how-to-disable-driver-signature-verification-on-64-bit-windows-8.1-so-that-you-can-install-unsigned-drivers/
  • Make sure you have all USB devices removed/ejected, to minimise any chance of clashing
  • Before plugging in the Digispark or running the Arduino IDE you must install the driver.
  • To install the driver go into the folder you just unzipped and go to the “Digispark – Windows Driver” folder. Inside that folder run the InstallDriver executable file. Go through the wizard to install the Digispark driver
  • Plug in your digispark and your drivers should be installed
  • When complete go back to the folder you unzipped and run the Arduino executable to open the Arduino IDE.

 Loading and running your first Blink test

  • Start the Arduino IDE from wherever you extracted it, arduino.exe
  • Make sure the Digispark is selected under > Tools > Board
  • Make sure Digispark is selected under > Tools > Programmer
  • Click > File > Examples > Digispark_Examples > Start
  • Make sure your Digispark is unplugged
  • Click the ‘Upload’ button – an arrow pointing to the right and when it’s done compiling, plug your Digispark in
  • Your Digispark will after about 10 seconds start blinking – woohoo

Now play with the Delay which is in milliseconds to see what happens, remember you have an on and off delay. You’ll need to unplug and replug each time you want to load new code. Make up a USB cable with a switch to simplify this procedure.

If you have the RGB Shield

  1. Start the Arduino IDE from wherever you extracted it, arduino.exe
  2. Make sure the Digispark is selected under > Tools > Board
  3. Make sure Digispark is selected under > Tools > Programmer
  4. Click > File > Examples > DigisparkRGB > DigisparkRGB
  5. Make sure your Digispark is unplugged
  6. Click the ‘Upload’ button – an arrow pointing to the right and when it’s done compiling plug in your Digispark
  7. Your Digispark will after about 10 seconds start cycling through colours

If the computer does not recognize the Digispark try the following:

  • Try connecting it to another USB port or system
  • Try connecting it to the rear ports (if a desktop)
  • Try connecting it to a USB hub
  • Try a powered USB hub

If it won’t upload: Did you set your board AND programmer to Digispark in the Arduino IDE? If your Digispark doesn’t slide easily into your USB port it needs a little filing to remove tabs from when the board. Feel on the edge that goes into the USB and you’ll feel what’s stopping it from sliding in nicely.

Digispark pinouts

All pins can be used as Digital I/O

  • Pin 0 ? I2C SDA, PWM (LED on Model B)
  • Pin 1 ? PWM (LED on Model A)
  • Pin 2 ? I2C SCK, Analog
  • Pin 3 ? Analog In (also used for USB+ when USB is in use)
  • Pin 4 ? PWM, Analog (also used for USB- when USB is in use)
  • Pin 5 ? Analog In

Model A & B

Taken from http://digistump.com/board/index.php?topic=134.0

Model B was the design we presented on Kickstarter (or the final version of it) LED was on P0 because that made for a very simple quick start, the trace was cut-table for \”advanced\” users using I2C – these are what we put into production right after the Kickstarter ended.

After we started to see more and more people buying and adding I2C devices (at first they were the least popular) and through our own work with the Digispark found that I2C was much more essential then we thought we made the change to Model A (called model A since it will be the main version moving forward, unless we revise it again) – so we ended up with 1/3 model B and 2/3 model A – we had to decide between this or all Model B version, we thought it\’d be better to push the change mid-production rather than have everyone get a Model B. That said we feel Model B works just as well, we personally cut the LED once we have a circuit debugged anyway, it is easy to do, and is the device presented on the Kickstarter.

Identification

Three models have been shipped. They have no feature differences, only a different connection for the on-board LED.

Model A

You can identify your model by the presence of “rev2”, “rev4”, or nothing on the top (the side with the gold connectors) of the USB end of the Digispark.

The on-board LED is connected to P1. This board should cause no conflicts with any devices, but remember the LED is on pin 1 not pin 0!

Model B

No marking: The on-board LED is connected to P0 This board requires the trace to the LED to be cut (or the LED desoldered) if you’d like to use it with I2C devices

Use an exact-o knife or similar small sharp blade. The area that needs to be scored or cut is outlined with a white box on the board – highlighted in red below for clarity.

To reconnect the LED for non I2C use, one can solder across the white box from the led to the closest pin of the IC.

12 thoughts on “Digispark – The micro-sized, affordable, Arduino enabled, USB development board!”

  1. The digispark sucks big-time. I am running Win-8 professional and I have spent about 6 hours trying to get this fucked-up piece of shit work. I’ve loaded the drivers correctly, but I keep getting an error message saying “USB device not recognized.” The drivers install without a hitch and the loading program works, but I get nothing but the USB error message.

  2. Ron – we haven’t heard from you here at Digistump – so drop us a line at [email protected], it sounds like you may have a faulty one (we have a very low 0.2% failure rate, but failures still happen) – and we’d be more than happy to send you a new one so you can see that it isn’t a “fucked-up piece of shit” but rather a product used by over 9,000 people with relatively few issues.

    Grant – hope you don’t mind that we linked to this from the wiki – thanks for a great tutorial! We will be releasing fully signed drivers soon – we are about to bite the bullet to get all the required signing certs.

    Thanks,
    Erik
    Digistump LLC

  3. I was able to get digiSpark to work on an old Windows Vista last year, but it has died.
    Now I also am using Windows 8.1.
    I may have inserted the digiSpark before installing the driver.
    Then I installed the driver, but I get the message:
    avrdude_original: usbdev_open(): did not find any USB device “usb”
    I also followed the directions above about disabling driver signature enforcement. Then I

    installed the driver again, but I get the same error.
    Can you help?

  4. I own a olimexino-85 tiny, after I’d soldered everything and istalled the Digispark Sw for arduino confor the precedet instructions, i started The start program and after a look to Tools>Board i see Digispark 16(Mhz) no USB),8(Mhz) no USB),1(Mhz) no USB), all (tiny Core)
    Serial Porto brought only com1, Programmer Digispark, the Status line recod Digispark no USB (tiny core) on Com1. running the start program I connected the Device It begun blinking IDE brought the error device search timed out, soupose becouse the USB is not present.
    where kann i search and install the USB?
    Have you other suggetion for the malfunktionnig?

  5. I have one of these from Ebay. Windows keeps saying it isnt recognised…… I have tried everything I can find online, i think the best place for this Digispark is the bin.

  6. I also have windows 10 and have not found the trick in getting it to communicate. I can find digispark bootloader but in the arduino ide on the bottom left corner it says ” digispark com port5, in the menu i cannot access the port option

  7. SYSTEM:
    Windows 8.1 x64

    PROBLEM 1:
    You try to program the Olimexino-85 (or Digispark device, or whatever brought you to this page), and a Windows error message pops up: “USB device not recognized” then something like “The last USB device you connected to this computer malfunctioned, and Windows does not recognize it.”

    TROUBLESHOOTING 1:
    1) Re-install the latest Arduino IDE (now it’s 1.6.11)
    2) Download the Digistump.Drivers.zip again (now it’s 1.6.7) from:
    https://github.com/digistump/DigistumpArduino/releases/download/1.6.7/Digistump.Drivers.zip
    3) Unzip this drivers file and run the InstallDrivers.exe Wizard.

    PROBLEM 2:
    The drivers finish installing but the Ports driver has failed:

    Install failed: Digistump LLC (usbser) Ports (08/16/2014 1.1.0.0)
    Ready to use: libusb-win32 Digispark Bootloader (01/17/2012 1.2.6.0)
    Ready to use: libusb-win32 DigiUSB (09/02/2014 1.2.6.1)
    Ready to use: Digistump LLC (digistump.com) (usber) Ports (09/02/2014 5.1.2600.1)

    TROUBLESHOOTING 2:
    Just plug in the little Olimexino-85 or Digispark device to a USB port. It might give the Problem 1 again but ignore it for now.
    1) Go into Device Manager, under Universal Serial Bus Controllers, look for item with the yellow caution “!” next to it. It’s probably called: Unknown USB Device (Device Descriptor Request failed)
    2) Right click on it, then click on Properties.

    PROBLEM 3:
    The device status has an error message in it, like this:

    Windows has stopped this device because it has reported problems. (Code 43)
    A request for the USB device descriptor failed.

    TROUBLESHOOTING 3:
    Try updating the driver.
    1) Go to the tab for Drivers and click Update Driver.

    But what do we do if it says:
    The best driver software for your device is already installed. Windows has determined the driver software for your device is up to date. ??

    TROUBLESHOOTING 4:
    Try checking the file called DigiSerial.inf, maybe it’s missing the usbser.sys line.

    1) Search computer for DigiSerial.inf, find it buried way, way, way in the depths of your User folders.
    2) Open it in a WordPad or similar and find the line that say [DriverInstall.NTamd64.CopyFiles]
    3) Check that both these files are listed underneath there:
    usbser.sys
    lowcdc.sys

    But what do we do if they’re already there??

    DIAGNOSIS OF PROBLEM:
    Seems like we need to fix the initial Ports installation failure. This is the magical answer that many people have been asking for over the past few months…

    Please help!

  8. OK — good news. If you read my post from Sept 9th and are still frustrated that your Olimexino-85 isn’t being read as a device by Windows, I’ve finally got mine working. I had to manually install a special driver, and I used a small program called “Zadig” to do it for me. This process fixes the initial Ports installation failure, and after doing the following steps, I successfully programmed my Olimexino-85 with a little blink program. I will only add that I did not have to re-program the bootloader that came with it, which was a suggestion that came straight from support (at) olimex.com. (Their other final suggestion was to check the soldering around the USB socket.)

    If you have Windows Vista or later: (includes Windows 8 & 10)
    1) Create a folder on the Desktop called “Zadig” or similar.
    2) Open an empty Notepad file.
    3) In Firefox, go to https://github.com/micronucleus/micronucleus/tree/master/windows_driver_installer
    4) Right-click the zadig_2.1.2.exe file link and save it to your folder. Check in Windows Explorer: If the filename has changed to “.htm” for internet protection, rename the file back to just “.exe”.
    5) Left-click on the Zadig.ini file link to go in and see its contents (31 lines). Copy & paste the entire text into a new Notepad file and save it with the .ini extension, in your Zadig folder.
    6) Go back to the weblink in step 3 (go up one level).
    7) Left-click on the micronucleus.cfg file link to go in and see its contents (8 lines). Copy & paste the text into a new Notepad file, and save it with the .cfg extension, in your Zadig folder.
    8) In Windows Explorer, look in the Zadig folder and confirm you have these 3 files:
    – Zadig.ini
    – micronucleus.cfg
    – zadig_2.1.2.exe
    9) Connect the Olimexino-85 board to a USB port on your computer. Close the pop-up window if it tries to install a driver by itself.
    10) Run the zadig_2.1.2.exe application. If necessary, allow the program to make changes to your computer. (The verified publisher is Akeo Consulting.)
    11) In Zadig, click: Device > Load Preset Device, and select the micronucleus.cfg in your Zadig folder. You should see “Micronucleus” written inside the text box.
    12) Next to the green arrow, change the WinUSB selection to be the libusb-win32 selection.
    13) Underneath the libusb-win32 text box is the installation button. Make sure to select “Install Driver” from the drop-down menu on the button, then click on the button to activate the installation.
    14) You can check to see if the installation was successful: in Zadig, click Options > List All Devices. Look for the “Digispark bootloader” option.

    I hope this works for you too. 🙂

  9. I spent the whole night to make this board work. The windows 10 kept connect and disconnect the board. But finally I got the trick to make it work. Just discard all kinds of errors you have. If you get the Arduino IDE to have the board in its list, then just call up an example program and press upload. Once the IDE finish compiling the code. It will say searching for the board…time out in 60 seconds. Now just plug in your board in the USB slot it will be found and the program will be uploaded into the chip. Take out the board from the USB slot. If you need to upload a new code. call it up in Sketch and click upload. Plug the board into USB slot only during the sketch is searching for the board in the time of 60 seconds.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.